Back to overview
Resolved

Logins and signups are failing

Jul 16, 2026 at 8:17am UTC
Affected services
auth.truefoundry.com

Resolved
Jul 16, 2026 at 10:01am UTC

The root cause was the dependence of an upstream provider on cloudfront which underwent a global downtime. We are completely up now

Created
Jul 16, 2026 at 8:17am UTC

Logins and signups are failing for all users