Back to overview
Degraded

AI Gateway: chat/completions API with 'prompt_fqn' failures

May 22, 2026 at 6:52am UTC
Affected services
Global - https://gateway.truefoundry.ai
North Virginia, United States - (ORF) - https://orf.gateway.truefoundry.ai
Toronto, Canada - (YYZ) - https://yyz.gateway.truefoundry.ai
San Francisco, United States - (SFO) - https://sfo.gateway.truefoundry.ai
Dallas, Texas, United States - (DFW) - https://dfw.gateway.truefoundry.ai
London, United Kingdom - (LHR) - https://lhr.gateway.truefoundry.ai
Madrid, Spain - (MAD) - https://mad.gateway.truefoundry.ai
Gavle, Sweden - (GVX) - https://gvx.gateway.truefoundry.ai
Sao Paulo, Brazil - (GRU) - https://gru.gateway.truefoundry.ai
Cape Town, South Africa - (CPT) - https://cpt.gateway.truefoundry.ai
Doha, Qatar - (DIA) - https://dia.gateway.truefoundry.ai
Singapore, Singapore - (SIN) - https://sin.gateway.truefoundry.ai
Mumbai, India - (BOM) - https://bom.gateway.truefoundry.ai
Sydney, Australia - (SYD) - https://syd.gateway.truefoundry.ai
Melbourne, Australia - (MEL) - https://mel.gateway.truefoundry.ai

Resolved
May 22, 2026 at 4:42pm UTC

We have identified the issue in the authorization of prompts in AI Gateway leading to failures in request containing prompt_fqn in chat/completion API. This was because of a bug in the gateway code that affected prompt hydration in the gateway and resulted in authorization errors. We will be adding more tests to safeguard this code path so that this doesn’t happen again in the future. We have resolved the issue completely.

Created
May 22, 2026 at 6:52am UTC

chat/completions API request with promptfqn in the request body started failing with error: 'An error occurred while processing prompt configuration: Prompt not found or access denied: <promptfqn>'.